If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Poll: Is there something wrong in my post?
This poll is closed.
Yes
0%
0 0%
No.
0%
0 0%
Total 0 vote(s) 0%
* You voted for this item. [Show Results]

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Seriously Pro F3 X4RSB Setup
#1
Finally got sbus and telemetry working with F3 Controller and X4RSB receiver.   Wanted to share working setup.  Will add more info and pics when I get time.   The youtube videos 'mainly from Painless360' got me 95% done.  Could not get telemetry to transmit to Taranis Transmitter.  Finally fixed with signal diode.  The following is from my notes.
/*
X4RSB has SBus connected to Pin 3 of IO_2 connector which is also the UART3 RX pin.  This works.  Now I cannot use the other UART3 header for telemetery according to Seriously Pro F3 manual.   Painless360 video shows UART2 Pin 3 being used but he sacraficed his gps to do it.  He also mentions you can use IO_2 pin 6= ch8/Sonar Echo as a TX for smartport telemetry.
In clean flight enable softserial then in ports softserial2 Telemetry Tab, set to smartport, auto.  The 5V IO to 3.3V TTL did not seem to matter.  X4RSB is Tolerant!  This did not work at first.
FIX: Same as on my Naze32.  You need a signal diode'I used 1N4148' dark band connected to IO_2 pin 5 Ch7/Sonar Trigger as RX, non-band side of diode connected to IO_2 Pin6 TX. Make sure the smart port wire is connected to IO_2 pin 5 RX only.  This worked Now I have telemetry on Taranis.  Cleanflight CLI telemetery_inversion = on.  I think I had to rescan for sensors on the Taranis transmitter after soldering in diode.
*/


Attached Files Thumbnail(s)
   
#2
you can also do it without the diode bro, just jump pins 5 and 6.
Reply
#3
(10-Jul-2016, 02:25 AM)JimmyLe813 Wrote: you can also do it without the diode bro, just jump pins 5 and 6.

Thx JimmyLe813.  I went back and shorted pins and VFAS, Acc etc telemetry was still working.  Tried on F3 and Naze32.  Both worked with RX, TX pins shorted.  I suspect I was not getting telemetry due to the transmitter being too close when I was connecting.  Not 100% sure though as I was getting RSSI, Rcvr Voltage etc but not the VFAS, Acc etc when I originally could not get telemetry from flight controller working.  Ugh!  At this point it seems to work shorted or with a diode.  If transmitter is too close <2 feet you may lose telemetry.   Putting the antennas right next to each other you should hear Telemetry Lost warnings then Telemetry recovered as you move away.
Reply
Login to remove this ad | Register Here
#4
(10-Jul-2016, 04:07 PM)j_keiter Wrote: Thx JimmyLe813.  I went back and shorted pins and VFAS, Acc etc telemetry was still working.  Tried on F3 and Naze32.  Both worked with RX, TX pins shorted.  I suspect I was not getting telemetry due to the transmitter being too close when I was connecting.  Not 100% sure though as I was getting RSSI, Rcvr Voltage etc but not the VFAS, Acc etc when I originally could not get telemetry from flight controller working.  Ugh!  At this point it seems to work shorted or with a diode.  If transmitter is too close <2 feet you may lose telemetry.   Putting the antennas right next to each other you should hear Telemetry Lost warnings then Telemetry recovered as you move away.

RSSI and receiver voltage info comes directly from your receiver that's why that information is always sent back to your transmitter. all other information comes from the flight controller, that's why if it's not set up correctly you'll still get RSSI and receiver voltage but nothing else. glad to hear you got it going tho Smile
Reply
#5
   
How to use Aux 2 to drive a servo or a channel driven beeper like the Turnigy 3-In-1 Battery Monitor, Signal Loss and Lost Airplane Alarm.  
On cleanflight configuration page scroll to bottom and check the servo_tilt box.  Save!
On the Seriously Pro F3 I had to use output pins 7,8 not 1 and 2 as suggested for the naze32.  Also Servo1'not Servo0' in in the servos tab of cleanflight corresponded to Output Pin 8 on F3 Board.  The aux channels were listed as A1 A2 etc. on the cleanflight servos menu.  Check the box of the Aux channel you want to use.
Don't setup a range under Modes for CamStab.  You don't want the controller trying to stabilze the servo if you just want to use an Aux Channel to drive it.  Servotilt is checked. I did verify with two sevos on output pins 7 and 8 and camstab enabled.  Noticed intermittent functionality from the Hobbyking Turnigy 3-In-1 Battery Monitor.  Sometimes it would chirp at low volume when I first power up.  Unplug and re-plug and it would work fine off the Aux2 switch F on Taranis.  I checked the aux2 end limits in cleanflight.  1000,2000.
Reply
#6
smartport telemetry is quite simple on the spr f3 and x4r

Reply
Login to remove this ad | Register Here


Possibly Related Threads...
Thread Author Replies Views Last Post
  the 800 hz flight controller w ios setup marvedjensen 0 274 22-Jan-2017, 02:26 AM
Last Post: marvedjensen
  LED lighting setup RENOV8R 5 543 12-Jan-2017, 01:01 AM
Last Post: varkokonyi
  Telemetry Fix Naze32 to X4RSB with 1N4148 diode j_keiter 1 533 05-Jul-2016, 10:51 PM
Last Post: Oscar