If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery charger run amuk....
#1
Ok...so I have this battery charger made by turnigy.  Its a TB6AC+80W.  I have searched the documentation, the internet, my soul...everything I could think of and have not found an answer.  Maybe someone can tell me what the hell I am doing wrong, if anything.  When I put a battery on to charge it seems normal at first, but really really slow.  When the voltage comes up to 12.6 (on a 3S) and the amperage has dropped to .1 or 0, it should shut down, right???  Well it doesn't ...it doesn't take the voltage any higher, the amps in just keeps jumping around between 0, .1, or ,2.  The amps it says it has put back in the battery just keeps climbing.  I let it run t he other day (I stayed with it) just to see when it would cut off.....three hours later it said it had placed 3300 mAh back into an 1800 mAh battery????  I finally just shut it down.  I have found no where to calibrate this thing and my other charger (very similar...think it's got the same chip in it) charges that battery in about an hour.  Anybody got any ideas on this????  Leave it to me to have some weird a$$ problem.  Thanks all!!
"Damn the torpedoes!!!  Full speed ahead!!!"
#2
It's the balancing. It's constantly taking out amps from higher voltage cell and putting more into lower ones in order to balance them all.. Both "in and out" amps count, so it's normal to see charged capacity higher than the pack itself... But 3Kmah for a 1800 is a bit unusual... i would expect something like 1800-2000 if you discharged them to 3.6V per cell previously
maybe you should just stop charging manually in future when charge capacity is over 1800, and cell voltages are not too apart.
Don't be a LOS'er, be a FPV'er :) -- My Fleet
Reply
#3
My chargers all have a Balance Charge function, which is how I charge my batteries, in balance mode.

I agree with Oscar, does sound like a balancing issue.
My youtube channel

Reply
Login to remove this ad | Register Here
#4
I would agree with that, but I am not even trying to charge in balance mode.  I'm not even plugging the balance connector in.  Without using balance mode, that shouldn't be an issue, should it?
"Damn the torpedoes!!!  Full speed ahead!!!"
Reply
#5
(01-Aug-2016, 03:07 AM)sirdude Wrote: I would agree with that, but I am not even trying to charge in balance mode.  I'm not even plugging the balance connector in.  Without using balance mode, that shouldn't be an issue, should it?

Really, no balance lead plugged in?  that sure is odd that the charger even charges, normally you get a "Connection Error"
My youtube channel

Reply
#6
Both of my chargers have several option for charging...charge, balance charge, fast charge, discharge and storage charge,  I only balance charge it when the cell voltages differ by about .04 volts or more, or every 5th charge...which ever occurs first..  Takes longer to balance charge, for obvious reasons.
"Damn the torpedoes!!!  Full speed ahead!!!"
Reply
Login to remove this ad | Register Here
#7
(01-Aug-2016, 03:59 AM)sirdude Wrote: Both of my chargers have several option for charging...charge, balance charge, fast charge, discharge and storage charge,  I only balance charge it when the cell voltages differ by about .04 volts or more, or every 5th charge...which ever occurs first..  Takes longer to balance charge, for obvious reasons.

None of my Chargers will charge at all without the balance lead in.
My youtube channel

Reply
#8
Apparently one of mine wont do it correctly.  Have no problem with the other one....although I never have figured out how it knows that it;s a 3S or 4S without the balance lead plugged in, but it does know...identifies it and request confirmation before I can start it.  Go figure......
"Damn the torpedoes!!!  Full speed ahead!!!"
Reply
#9
Maybe the LiPo's got the wrong label, you have been flying a 3200mah pack all along LOL Big Grin
Joke aside, I would always charge at balance mode... ALWAYS! Smile it's for safety...
Don't be a LOS'er, be a FPV'er :) -- My Fleet
Reply
Login to remove this ad | Register Here
#10
Understood Oscar.  I've got in the basement now inside a stainless steel container charging a fairly new battery (in balance mode) and I'm just gonna let it eat until it's done, or blows something up. Dodgy   Have a closed circuit camera down there and I am watching it as I work so if something goes south, I'll know.
"Damn the torpedoes!!!  Full speed ahead!!!"
Reply
#11
Ok....I guess it does work.  Just seems like it is taking an excessive length of time to charge.  This is an 850 mAh 3S that started out at about 11.2 volts and it took almost 2 hours and exchanged almost twice the number of mAh that the battery is rated at???  Oh well...I suppose I should be happy it works at all. Big Grin   Thanks Oscar and Biggles for your help! Big Grin Big Grin

"Damn the torpedoes!!!  Full speed ahead!!!"
Reply
#12
(01-Aug-2016, 08:37 PM)sirdude Wrote: Ok....I guess it does work.  Just seems like it is taking an excessive length of time to charge.  This is an 850 mAh 3S that started out at about 11.2 volts and it took almost 2 hours and exchanged almost twice the number of mAh that the battery is rated at???  Oh well...I suppose I should be happy it works at all. Big Grin   Thanks Oscar and Biggles for your help! Big Grin Big Grin

You might check you settings on that charger.  It shouldn't take 2 hours to charge a 3s pack of that size.  Is it possible you have it set to cycle the battery 3 or 4 times?
Reply
Login to remove this ad | Register Here
#13
Yeah...I figured about 40 to 50 minutes.  As far as I know it's not set to cycle....I haven't seen anywhere to set that, but I haven't really been looking either.  It's a pretty simple straight forward charger, but I agree.....shouldn't take that long.
"Damn the torpedoes!!!  Full speed ahead!!!"
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Keeping battery connected rryyyaann 5 31 32 minutes ago
Last Post: Carl.Vegas
  Temperature Affects Battery's power and max discharge rate! Oscar 12 1,128 23-Apr-2017, 10:36 AM
Last Post: Grisha0
  Killed my first battery (mostly just complaining) Carl.Vegas 6 188 07-Apr-2017, 10:27 AM
Last Post: Carl.Vegas
  Defective Battery? Carl.Vegas 3 220 02-Mar-2017, 11:20 AM
Last Post: Carl.Vegas
  Tutorial ISDT SC-608 and SC-620 LiPo Charger Firmware Update Oscar 22 17,571 01-Mar-2017, 06:36 PM
Last Post: Oscar