If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tuning help
#1
I read possibility of pid tunning from blackbox log.
So i came here for some help with that.
My quad spec:
450mm quad
A2012 1400KV motor
ESC seems some generic build.
propeller is 10*4.5".

Here is cli dump
This is the blackbox log.

I'm only trying to hover inside a hall.(haven't tested in field) & quad always trying to move forward right although pitch , roll, yaw at mid.
1 monent take off & then land.(throttle low, not even good lang, so quad may have jumped at landing)
I tried to reduce noise from d term & gyro. Still not eliminated completely.
Will appreciate all help.
#2
There is a lot of noise in the gyro, you have first to try to reduce this, did you balace the props.
It seems also that you motors not start to spin all at the same time at the beginning you see that motor 3 isn't spinning if the other motors are already spinning.
Reply
#3
prop balanced
esc caliberated from 1000 to 2000
all motor start at 1064~66
some time it differ(only during flight, how ever when i test without prop all started al 1064~66)
Reply
Login to remove this ad | Register Here
#4
If you power up your quad, make all the ESC's at exact the same time there start up tune?
Reply
#5
i don't know how to make all motor to start at same throttle.
I did this to caliberate esc in cleanflight.
set throttle to 2000 in cli with usb only --> saved--> started cc3d with battery--> connected usb-->set throttle to 1000
got esc music & thought it got caliberated.

How to start all motor at once??can you explain or point me in that direction
Reply
#6
(06-Dec-2016, 08:11 PM)Addicted Wrote: i don't know how to make all motor to start at same throttle.
I did this to caliberate esc in cleanflight.
set throttle to 2000 in cli with usb only --> saved--> started cc3d with battery--> connected usb-->set throttle to 1000
got esc music & thought it got caliberated.

How to start all motor at once??can you explain or point me in that direction
Simple Cleanflight ESC calibration is as follows:
With battery unplugged, go into motor tab of Cleanflight and using master slider, slide all to maximum
Plug in your battery, ESCs will sing a song
Quickly slide back down to minimum and ESCs will sing another song, they're now calibrated
Reply
Login to remove this ad | Register Here
#7
idk why i'm talking with you.Thanks for pointing that.But i already did it.i hope someone more experienced help me.
i caliberated using cli in cleanflight.
It's same as motor tab in gui.
basically my esc caliberated already.
Anyway is it worth moving to betaflight from cleanflight???cleanflight latest 1.14 & 1.14.1 was buggy.so i reflashed 1.13.is there any issue like that in beta flight?
Reply
#8
You can try betaflight, but if your "generic" esc #3 is the cause of your fits, it's not likely to change things.  (I'm just assuming you can't get to the individual esc's with blheli or simonk since you didn't say.)

As far as "noise", it could be that even with your props balanced, you may need to balance the motors.  I had to do that on my 450.  There's videos on-line to show you how to do that.

Quote:idk why i'm talking with you.i hope someone more experienced help me.

And as far as your first sentence above, you did say in your OP "will appreciate all help".  You may not have meant it to sound that way, but it came off a bit poorly.  Good luck with sorting it out.
Reply
#9
sorry for that rude comment.
I found that my esc has SimonK firmware.
Will post result after caliberating ESCs individually & reducing motor vibration
Reply
Login to remove this ad | Register Here
#10
I decreased motor vibration.(may be not completely, also that fc is soft mounted with that damping rubber i got wih cc3d)
Now, this is the blackbox log.
my quad jumped many time when trying to hover(since i'm using diy landing gear made with wire).So there may seem accelerometer n gyro disturbance in some flight.
This is the cli dump.
i haven't find how to communicate with SimonK esc.
so didn't individually caliberate yet.
i think they are almost okay since 2 motor start at 1064 throttle, & other 2 at 1066.
& i set min throttle to 1100
Reply
#11
What modes are you using? If it drifts in level mode you can trim that.
If it's normal rates mode it sounds like PID issue, maybe i-term too low?
Sorry can't help much, it's a long time since i used cleanflight the last time.

Regarding vibrations, yeah you have filters already pretty low.
Balancing props/motors or isolating the FC.

With betaflight and its notch filters you could adress certain noise frequencies more specifically.
For cc3d i recommend flashing with an FTDI adapter. The OPBL version has limited functionality.
Reply
#12
it's angle mode.
& i'm unable to trim rc  command to mid.with certain subtrim value , mid is 1502 & if i increase subtrim value by 1 it would be 1499.can't make itexact 1500.
ya, i'm using ftdi for flashing bin.Not hex file i think.
i installed latest betaflight.it gave same issue that latest cleanflight gave me.My quad flipped & broke 2 propeller.may be accelerometer issue like in latest cleanflight.

fc is soft mounted by this.Will  serach for reducing noise/vibration by other method & post
Reply
Login to remove this ad | Register Here
#13
What PID controller are you using? I tried Luxfloat and got all kinds of oscillation and vibrations that I couldn't seem to totally tune out. I went back to rewrite and everything was fine.
Reply
#14
The most ideally a gyro trace looks like this:

You may have some little noise on the lines but not to much, but you gyro looks like a mess, this is your gyro:


That is a lot of noise, you have to reduce this, otherwise you cann't tune your quad, you also see that motor 3 and 4 are not spinning at all, that's also strange
But you need to reduce the noise into the gyro.

This is what i meant with a good ESC calibration, watch the movie, he let you also here what it sounds like when the ESC's are not in sync at power up.

Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Newbie at tuning Gr8Stog 5 223 19-Oct-2017, 07:05 PM
Last Post: Gr8Stog
  HELP! Tuning by feel, can't seem to reduce my propwash Skypup831 2 216 01-Oct-2017, 02:56 PM
Last Post: fftunes
  HELP Tuning beginner quad Daniel45 10 391 11-Sep-2017, 05:12 AM
Last Post: Daniel45
  New to PID Tuning Graknil 3 434 12-Aug-2017, 11:43 AM
Last Post: fftunes
  New to PID Tuning Graknil 0 144 11-Aug-2017, 04:30 PM
Last Post: Graknil