If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GRRR.. So ticked off about EV800 Goggles
#1
I have been waiting 4 to 5 weeks for these EV800 to arrive and begin flying FPV. I have trained on Freerider a ton and got my cam and VTX setup as well. I got them in yesterday, tried them and they worked after fixing an issue with minimosd. I turned it all off for the night and let them charge.

When I get home today, I take the quad and EV800 outside to fly FPV for first time.. get everything powered on and take off. I make it about 25 feet up when the screen goes fuzzy then blank. SERIOUSLY?! At first i thought something must have not been clipped on completely, took them off and landed safely.. everything was fine. Try power cycling goggles the screen just blinks and goes blank... WTF!

The brand new EV800 are dead; If I take a flashlight and point it to the screen you can view the image just barely. The backlight is dead already... so I'm kind of pissed and hate having to wait another month for replacement. I will probably ask for refund and go with a US vendor this time.
ZMR 250CF // RS2205 2300kv // RS20A 4in1 // SP F3 // CleanFlight // FS-i6 + ia6b Ibus
#2
Ahh dude, I feel your pain, almost. My goggles 2 sent in Jan by BG got lost, I finally received them last month, luckily fully working. Annoyingly all my motors are busted now, so after only a week of flying FPV, I still can't use them!
Windless fields and smokeless builds
Reply
#3
I've never had a problem with my EV800s, actually sounds like your battery is just not charged properly. They need to be charged with a 12V/1A power source
Reply
Login to remove this ad | Register Here
#4
(23-Jun-2017, 01:48 PM)RENOV8R Wrote: I've never had a problem with my EV800s, actually sounds like your battery is just not charged properly. They need to be charged with a 12V/1A power source

The supplied cable is 5v 1A and I charged the battery full displaying green and verified voltage at 4.2v with a DMM as well as trying a 2s external battery pack with supplied JST connector. No change, backlight is not working. The image will display if quad is on, But you cannot see it unless you point a flashlight on it.
ZMR 250CF // RS2205 2300kv // RS20A 4in1 // SP F3 // CleanFlight // FS-i6 + ia6b Ibus
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Eachine EV800 pro? rryyyaann 2 186 04-Jun-2017, 12:47 PM
Last Post: rryyyaann
  Eachine EV800 AV in rryyyaann 4 447 18-May-2017, 03:58 AM
Last Post: Drross
Question Eachine TX526 VTX & EV800 Goggles (+ Runcam HD2) Mish 14 1,471 16-May-2017, 12:54 PM
Last Post: rryyyaann
  Discussion Beginner Goggles / VTX / VRX / DVR ? Aaron 10 304 12-May-2017, 11:37 AM
Last Post: Aaron
  Skyzone V2 Goggles sirdude 11 347 05-Apr-2017, 11:49 AM
Last Post: sirdude