If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fatshark LiPo Voltage Error on 1st Charge Attempt
#1
Equipment:

Fatshark Dominator V3
Stock Fatshark 7.4v 2s 1800mAh LiPo
Turnigy Accucell 6 Charger

Problem:
*Let me state first that the battery came with a bit of charge, and DOES power my goggles.

That stated, it's a 7.4v 2s LiPo battery and shows as having 1 CELL (there are only 2 wires on the "balance plug") reading at 6.16v.  When I attempt to charge it, I get an error on my Turnigy... something like, "cell voltage error".  When I unplug the "balance plug", and select Charge (instead of Balance Charge) I get the same error.

I am able to use my goggles right now, but the battery is obviously close to it's approx. 6v recharge point.  This string - https://www.reddit.com/r/Multicopter/com...ng_issues/ - addresses this problem directly, but they failed to discuss the chargers they were using.

The solution in the above forum thread is not viable for me (as far as I can see) as I cannot find anywhere that I can manually "turn off" the balance connector in my Turigy Accucel 6.

Does anyone have any insights to charging the Stock Fatshark 2s LiPo with a Turnigy Accucel 6?

*****

Thanks a bunch in advance!

- Mateo
#2
could you take a picture of the battery, with the balance lead in the shot?
it's not possible to read 6V+ with just 1 cell.. the charger is giving error could possibly caused by the voltage of 1 of the cell has dropped below 3V?
Don't be a LOS'er, be a FPV'er :) -- Blog - Facebook - Instagram - Twitter - Google Plus
Reply
#3
Just connect the fatshark batt directly with the included adaptor to any lipo charger, you dont have to connect the other wires to the balance port, fatshark batts has its own internal circuit for balance charging
Reply
Login to remove this ad | Register Here
#4
(06-Jan-2017, 11:21 AM)Oscar Wrote: could you take a picture of the battery, with the balance lead in the shot?
it's not possible to read 6V+ with just 1 cell.. the charger is giving error could possibly caused by the voltage of 1 of the cell has dropped below 3V?

Hi Oscar,

I have taken a number of pictures, so that you can get the clearest understanding of what I'm seeing.  I'm sure that you know that Fatshark's stock batteries have a 2s balance lead that only has one red wire.


                       


Based on the total voltage, and the voltage indication of the 1 Cell displayed, I can only assume that Fatshark provided a "bad" battery, as I have only used the battery for 3 minutes to verify that the VTX and the Goggles were communicating... and they are Smile.

(07-Jan-2017, 04:38 AM)will0w Wrote: Just connect the fatshark batt directly with the included adaptor to any lipo charger, you dont have to connect the other wires to the balance port, fatshark batts has its own internal circuit for balance charging

Hi will0w,

This doesn't work for me :/
Reply
#5
Here is an article that might apply (looks like you might need to update your accucel firmware):
https://www.reddit.com/r/Multicopter/com...e_battery/
[-] The following 1 user Likes sloscotty's post:
  • Elektryk
Reply
#6
(09-Jan-2017, 07:45 PM)sloscotty Wrote: Here is an article that might apply (looks like you might need to update your accucel firmware):
https://www.reddit.com/r/Multicopter/com...e_battery/

Sweet!!!

I am working on getting the SkyRC Chargemaster software on my PC... which is a journey unto itself, but it looks like you have pinpointed the problem, sloscotty.

I will update the thread once I resolve, or hit a wall Smile
Reply
Login to remove this ad | Register Here
#7
        Ok, new issue.

Got up to date ChargeMaster software on my computer.  Downloaded the updated "patched" firmware to my computer.

Problems:

1)  the ChargeMaster software shows no Firmware for me to update (though indicates my current version), and through the help button, and searching for a bunch of minutes on the internet, I cannot find out how to make firmware versions appear in the "Firmware list:"

2)  there are 4 files that came with the updated firmware download for my Turnigy Accucel 6 - DFU.dll, DFU.exe, fw_1.13_original.bin, and fw_1.13_patched.bin.  I do not know which of these files is relevant, or how to make the ChargeMaster software see them.

Any thoughts - @sloscotty, @oscar... anyone?

Image attached showing what I see.
Reply
#8
Looks like you need to use DFU.exe.

See this post in RCGroups: https://www.rcgroups.com/forums/showpost...stcount=16
[-] The following 1 user Likes sloscotty's post:
  • Elektryk
Reply
#9
(09-Jan-2017, 10:24 PM)sloscotty Wrote: Looks like you need to use DFU.exe.

See this post in RCGroups: https://www.rcgroups.com/forums/showpost...stcount=16

Hallelujah!!!  Praise Quad!!! Wink

Thank you so much for your time and help sloscotty.  I can now FPV with abandon.
Reply
Login to remove this ad | Register Here
#10
(10-Jan-2017, 08:54 PM)Elektryk Wrote: Hallelujah!!!  Praise Quad!!! Wink

Thank you so much for your time and help sloscotty.  I can now FPV with abandon.

You are welcome - glad you got it to work!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Slightly Crushed LiPo ok to use? bsb395 7 213 09-Aug-2017, 10:04 AM
Last Post: Carl.Vegas
  imax b6ac lipo charger (multiple charge) flabombarda 6 231 09-Jul-2017, 02:48 PM
Last Post: unseen
  Lipo storage DannyZ 9 289 11-Apr-2017, 02:59 PM
Last Post: Carl.Vegas
  Lipo storage charge DannyZ 5 242 07-Apr-2017, 01:10 PM
Last Post: DannyZ
  Installing a capacitor to reduce possible issues with voltage spikes. Jk007 10 365 06-Apr-2017, 12:03 AM
Last Post: RENOV8R