If you enjoy our forum, why not join us? :) Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FAQ for Brushed Motor Quadcopters on Clean/Betaflight
#1
#1 - Basic Setup

Quote:set motor_pwm_rate=32000 #This will set pwm frequency to 32kHz
set max_throttle=2000          #brushed boards will use 0-2000 as throttle
set min_command=1000       #just to make sure min_cmd is not misconfigured
set fast_pwm_protocol=OFF  #disable oneshot125
feature motor_stop                #motors stopped when not armed
set min_throttle 1000            #the throttle when all motors start to spin, you might need to increase it if your motors spins when battery connected (e.g. 1060)


#2 - My motors spin full speed as soon as I plug in the Lipo battery...

Possible Causes:
1. Check your battery polarity (reversed polarity can cause this sometimes)
2. Motor PWM Rate too low => Read on

Solution: Go to CLI and enter

Quote:set motor_pwm_rate=32000  

And save. 


#3 - My Quad doesn't arm with stick...

Solution: 
1. Check your yaw/throttle stick range in Receiver tab, make sure both channels can at least reach 1000-2000. If not, adjust it in your TX settings (google how to do it with your TX Model)
2. If you prefer arming with stick, make sure you haven't setup a switch to arm (in Mode tab)
A better FPV'er than LOS'er :) -- My Fleet
[-] The following 2 users Like Oscar's post:
  • Stan, KonradS
#2
Just as short remark to #3. The Eachine quads are shipped with arm binded to AUX5. If you do not reconfigure your TX and AUX5 is set to a potentiometer by default, it could be, that the quad is armed in the very moment you plug the battery in, because TX does not check the position of potentiometers.
Reply
#3
Interesting, my QX95 came with the motor_pwm_rate set to 1000. Seems 'ok'. Should I change it to 32000 or just leave it alone?
Reply
Login to remove this ad | Register Here
#4
(11-08-2016, 08:07 PM)JBFUK Wrote: Interesting, my QX95 came with the motor_pwm_rate set to 1000.  Seems 'ok'.  Should I change it to 32000 or just leave it alone?

in theory anything higher than 500 would work Smile
but i find higher rate gives me smoother flights. Experiment with yours, also pay attention to the motor temperature and time flight time, and use whatever gives you good result Smile
A better FPV'er than LOS'er :) -- My Fleet
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  New Product DasMikro Micro DSM2 Receiver for brushed quad Oscar 10 997 12-16-2016, 10:02 PM
Last Post: pakamon
  Discussion Brushed motors performance pakamon 5 221 12-07-2016, 08:29 PM
Last Post: pakamon
  2s Brushed Micro X doubleKO 4 211 12-06-2016, 11:03 PM
Last Post: doubleKO
  New Product NUKE Brushed Flight Controller FC - Furious FPV Oscar 5 3,363 12-06-2016, 07:48 PM
Last Post: Cranston
  Help QX95 Betaflight PID settings dump pakamon 2 936 12-04-2016, 05:00 PM
Last Post: pakamon