If you enjoy our forum, why not join us? :) Login removes all the ads too! Click here to register in a few simple steps

Login to remove this ad | Register Here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Camera cuts out on Flips and rolls
#1
Hi all Can any one point me out here please

I have my quad start playing on me again

When I do flip or roll cam cuts out for split sec like black screen.

Camera connected from PDB 12v bec and VTX same both connected on MATEC V2.1 PDB

I can do hard punch out without problem but when I do flip roll it cuts cam out

Regards Thinking
#2
I would start with checking all connections are tight/seated including antenna (probably not the problem since it's black screen), connections for power to VTx, power to camera, connection between camera and VTx, if you soldered any wires together to build customized leads check the continuity of them with a multimeter be sure to find a way to keep the leads connected while wiggling the wire.

If everything looks good then next I'd probably take the camera and hook it up to a TV (assuming you have the AV cable that they usually come with) and turn it over to see if it cuts out there... if it doesn't cut out or act funny when turned over, try shaking it while turned over, apply some g-force to it.

Not sure if that'll help, or if any of that is stuff you haven't tried yet, but I figured I'd throw out what came to mind for me.
carl.vegas
Current Quad(s): Operational: Slightly modified Vortex 250 Repairing: Bumble Bee, Diatone GT2 200, Ghost Pirat Need Tx: Eachine QX105/110 hybrid
[-] The following 1 user Likes Carl.Vegas's post:
  • Darozas
Reply
#3
Check connections like Carl sais, but cutting out to a black screen sounds very similar to an OSD reset caused by voltage sag. Do you happpen to have an OSD unit on board?

EDIT: hard punchout is clreating weaker voltage spikes in the system than fast flips and rolls - due to rapid braking and thrusting of motors during stabilisation after flip so this is not a weird behaviour.
Find me on Youtube and Instagram. I currently fly: NOX5, NOX5RAirblade Assault 130 and drive a scrap RC car
[-] The following 1 user Likes KonradS's post:
  • Darozas
Reply
Login to remove this ad | Register Here
#4
I had this happened to me. Turn out that one of the component desoldered but was still held together by the shrink wrap. Check to see if all the components are still intact.
[-] The following 1 user Likes voodoo614's post:
  • Darozas
Reply
#5
(21-Jun-2017, 08:06 PM)KonradS Wrote: Check connections like Carl sais, but cutting out to a black screen sounds very similar to an OSD reset caused by voltage sag. Do you happpen to have an OSD unit on board?

EDIT: hard punchout is clreating weaker voltage spikes in the system than fast flips and rolls - due to rapid braking and thrusting of motors during stabilisation after flip so this is not a weird behaviour.

Thanks for reply

But what I notice yesterday that its only cutting out in AIR mode. Its fine in ACRO mode even if I do flip and roll.

In AIR mode it cuts OSD then BLACK screen on flip roll its sounds more to me like Ground issue somewhere.

No I don't have on board OSD got MicroMinimOSD wired up.

But I have received my Omnibus f4 yesterday so gonna install this to see if problem still persist.

Regards
Reply
#6
(22-Jun-2017, 08:50 AM)Darozas Wrote: Thanks for reply

But what I notice yesterday that its only cutting out in AIR mode. Its fine in ACRO mode even if I do flip and roll.

In AIR mode it cuts OSD then BLACK screen on flip roll its sounds more to me like Ground issue somewhere.

No I don't have on board OSD got MicroMinimOSD wired up.

But I have received my Omnibus f4 yesterday so gonna install this to see if problem still persist.

Regards

Yes, thats a microminimosd problem (and many others built on the max chip) in my opinion. Try to give it a flight without the osd or put it on a separate power source/give it a filtered one.

Ground loops can be an issue too as suggested above.

Edit: in the past i have noticed that it gets better when the craft is tuned better. That may explain the difference when you enable airmode (you basically had to retune to use it in the past, not sure how it looks like now as i'm not flying without airmode)
Find me on Youtube and Instagram. I currently fly: NOX5, NOX5RAirblade Assault 130 and drive a scrap RC car
Reply
Login to remove this ad | Register Here
#7
I had this problem recently. In my case it was due to voltage spikes and drops from my ESCs caused by the regenerative braking. I installed a voltage step down leading to the vtx to solve the problem.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Discussion Best FPV Camera Settings Oscar 0 775 04-Jul-2017, 04:20 PM
Last Post: Oscar
  Camera for spacial recognition or 3D scanning? Nazty 1 109 03-Jul-2017, 02:15 AM
Last Post: RENOV8R
  Discussion The Go-To FPV camera? TomP7715 4 145 26-Jun-2017, 10:38 AM
Last Post: Carl.Vegas
  dust in camera sesnor Charpu5 1 86 25-Jun-2017, 08:37 PM
Last Post: cche
  Data Testing FPV Camera Latency Oscar 10 526 25-Jun-2017, 02:54 PM
Last Post: Oscar